Forum and Google Translate

Since the update, I always get the same error message when I try to translate a topic from another Language & Geographical Communities with Firefox.
And although I have selected “English” as Interface language, it translates this page into German for me.

BTW, with Chrome it works perfectly.

I moved this into its own topic as I think it’s unrelated with the other issue.

I usually don’t use Firefox, but I just tried its translation of a topic and had no issue. Are you using Firefox built-in translation (which it appears to be in beta), or some browser extension?

And what URL does the browser show when it shows that error page?

1 Like

That is the url:

I think it is the built-in translation (???)

I have just had various Wikipedia pages in different languages translated into German - they all work perfectly. The Community Guidelines, for example, are also translated without any problems. So it only seems to not work in the forum,

This URL is at a different website (notice the domain is When I tried the Firefox translation, it translated the page in place, without going to a different website. I’m using

Can you try using this too or do do you know what’s triggering the different behaviour? I’m running Firefox 127.0.2

Yes, that works - and then I can use this kind of translation.
But I’m still wondering why it hasn’t worked since the update the other way.

Can you double check that on Firefox installed add-ons you don’t have something related with google translate?

The reason I ask this is because the trouble may be on said add-on (if it’s the case you have one installed). The URL you were taken too has the bit /t/translation-in-firefox/864608/2 repeated in the URL – removing one of them makes it work. No idea why it’s appearing duplicate.


Yes, I removed one and it works :thinking:

Can you check if what you have installed is this:

(don’t install it if you don’t have it)

I think it is not the same add-on as mine, but I have it now deactivated as it works the other way

After some more poking, it doesn’t seem to be dependent on a particular add-on or even on Firefox, but on some weird interaction between Google Translate and Discourse.


  1. Go directly to
  2. Paste a URL to translate like
  3. Hit the translation icon/button

The same issue happens. I couldn’t make this happen with other website.

I have reported it to the Discourse team, but it’s unclear where the issue actually is.


Yes, it’s the same.

Thanks for your help and finding another way to translate topics.