Sorry, Postcard ID not found! Need help? And then "can't be registered anymore"

I got a postcard and tried to register it.

But then it says:
Sorry, Postcard ID not found!

Okay, fine maybe I haven’t read the ID correct or the sender used the wrong one.

So I tried several other options it might be, but none worked.

Finally, I used " Request help to find unknown ID"

Made two scans and filled everything out. To get the answer:
“Sorry, but XX-00000 can’t be registered anymore because the sender is no longer participating in Postcrossing. Consider it as a bonus postcard to you!”

Fine, what ever happend.

But my question is, why I couldn’t get this answer already in the first step and I would have saved my second step with doing all the scans and filling out?


First, commend yourself for making the effort. Second, postcards usually cannot be registered if they are over a year old.

Lately I registered a card from a member that is no longer participating and got this answer in the first step. Maybe in your case it is the combination of a card travelling for more than one year plus member no longer participating.

1 Like

You probably need to do both because the 1st answer is likely an autofunction of the site - it scanned for the # & couldn’t find it. The 2nd reply probably involved a real person checking your info - it’s a small team & that takes time.

1 Like

I think your first step was answered automatically by the Postcrossing website. Your second step goes into a queue of questions needing a human being to research it. There are only a few administrators on the site - remember, you do not pay anything to join Postcrossing - and only a small fraction of the members pitch in with donations - so be patient about all the wonderful free services you receive from Postcrossing.

And consider making a donation because every little bit helps them to cover the costs of web services for this huge and wonderful community, plus the costs of programming new features and trouble-shooting whatever comes up.

No it was not involved a real person, because it popped up the same way like the first massage did.
Of course, it is not a big deal and I understand it is a small team, but maybe a small tweak to fix it?

Who knows, I just wanted to mention it under suggestion, of course the site works perfect anyway and I’m happy with it.


Just because the message popped up like the 1st one doesn’t mean a person wasn’t involved. I can imagine they have a list of pre-done replies given how often the same answers are needed. Let’s see if someone from Admin answers here.

1 Like

The only person involved was me pressing the “Request help” button. (of course it was filled out)

…and then it changes to:

This is probably a recent change, maybe still work in progress. A few months ago I registered a card from “nobody” without incidents - it just showed up as sent by “account deleted”.

Or maybe this card of yours is both more than one year old, and sent by somebody who deleted their account? That is a scenario that I haven’t run into yet. It’s easy to check - look at a few of its “neighbors” - ID +/- a few - and when you find one that was registered, you’ll see when yours was drawn.


The (second) error should show directly on the receive a postcard page and I think this has been fixed in the meantime. Can you try again please?

If it still fails with a generic “Postcard ID not found”, can you message me the Postcard ID of this postcard if you still have it so I can take a look?

1 Like

This topic was automatically closed after 14 days. New replies are no longer allowed.