Odd behaviour with search button

I’ve noticed the search button behaving odd a couple of times. When I’m on topic (especially a topic that I visited before) and I click the search button, the page jumps up and shows previous posts instead of showing the search bar.

This wasn’t how it was before and it seems to be happening only on Chrome (Version 92.0.4515.131) which is my default browser. I checked this on Firefox and I don’t see this happening.

Desktop or mobile? Are you able to reproduce this consistently with Chrome, or only happens sometimes?

It’s tricky to address if we can’t reproduce it on demand.

Anyone else noticed this behavior?

I’m on a Windows 10 Desktop and yes, I’ve noticed this consistently for the past few weeks. I also don’t have any extensions turned on for this website.

Not sure if this is helpful but I took a few screenshots of me clicking on search on a Lottery Topic.

1 Like

Same here, every time since the last weeks, only use mobile, android

Just to be sure we are talking about the same: by clicking search you mean the magnifier icon on the top right, correct?

Can’t see what may be causing this — doesn’t seem to happen to me with Chrome, and it would be odd if this is specific to Windows.

Are you able to reproduce this on Discourse’s own forum?

Hum, on mobile it could be an ocasional mis-click (ok, a mis-tap) because tapping on the top of the screen is a shortcut to go up/back in the current topic — a sort of page-up. So this could be different from what @anon12838227 is reporting on Desktop.

Yes, I see this behaviour when I click on the magnifier icon. And I’m seeing this on meta.discourse.org as well. Unless I’m at the start of a topic or go to start, clicking on the magnifier doesn’t show the search bar.

Another thing I observed is that when I resized my window’s width to take up less than full width, and then clicked on search(magnifier icon), the search bar showed up.

Are you able to (temporarily) disable all Chrome extensions you may have installed — and maybe try with an incognito window also —, just to be sure this is not specific to your setup? I’ve seen extensions doing the weirdest things unintentionally. :sweat_smile:

It’s strange that I’m the only one seeing this :slight_smile: I reinstalled Chrome the other day but the behaviour persists. I had taken a screen recording on this site: https://i.imgur.com/1qdD2sv.mp4

And this was on the meta website: https://i.imgur.com/nVREzKb.mp4

Did you try with the extensions disabled? That’s more likely to interfere.

If you can reproduce it on meta (with all extensions disabled), would you mind reporting it directly on meta here?

I can do it, but as I can’t reproduce the issue myself, it would be quicker if they can ask you questions. Let me know if you prefer not to and we’ll figure some other way.

Yes, I had tried it by disabling extenstions and then removing them. Also tried it in incognito mode. Those recordings are from a fresh install of Chrome without the extensions. I think this is something that changed with the new release of Chrome. I am not able to downgrade Chrome but I looked up an older version of Chromium (Version 90.0.4430.0) and on that build, I don’t see this behaviour.

I think I can live with this for the time-being :slight_smile: I’ll just go to the start of the topic when I need to search.

I’m on the latest (stable) Chrome and still can’t reproduce it, but it could be specific to Windows somehow. I’ll keep this topic open for a while — lets see if more people are affected by this.

Meanwhile, a trick that may help on a desktop to circumvent this: if you hit the / key, it should open the search bar wherever you are.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.