[NOT A BUG] Can't Upload Photo For Sent Postcard

I drew an address yesterday, chose and wrote the postcard, photographed it, and have tried numerous times to upload the photo without success. I get the message in the accompanying photo, which means nothing to me.

I’ve sent and uploaded more than 700 photos, I’m not doing anything different from normal. Obviously, the postcard hasn’t reached the recipient, because I know I can’t upload once that has happened. (I only posted it this morning.)

Can anyone suggest what I could try to get this photo uploaded?

1 Like

Hello Louise.

This looks like a temporary problem. I’d suggest to try again later. It will probably work then.

1 Like

Agreed. Also have you tried the old trick of turning off and then on the computer again? That might help! :relaxed:

1 Like

It’s happened to me numerous times and I’ve only been postcrossing less than a year. Just try again later.

1 Like

I always use my phone for Postcrossing. I’ve switched it on and off about six times in the 24 hours I’ve been trying to upload this photo. I even got my tablet out, which I never use for Postcrossing, and couldn’t upload it using that.

Seeing as it’s already been 24 hours, when does it stop being a temporary problem, and become something more permanent?

Ups, you are right then. Thought it had happened just right before you posted.

I’m calling @paulo here to maybe give you better suggestions. :slightly_smiling_face:

Hope it gets fixed soon! :blush:

1 Like

I just requested an address and I can successfully uploaded the photo.
Maybe the problem is with your internet, or the size/type of the file, or anything I don’t know


Yes, I did check the file size and it’s 2. something (we’re allowed 16) so it’s not that.

1 Like

Thank you. We’ll see if there’s any other solution.

That looks like a technical issue which must be solved by the staff, so let’s wait for Paulo.

1 Like

Have you always tried it with the same photo?
Then you should simply test it with a different one - preferably one that you have uploaded before.

1 Like

Earlier today, I photographed the postcard again, and tried with the new photo, but that obviously didn’t work. I’ve just tried again with another picture of a different postcard, and no luck.

That’s very strange - hopefully Paulo can help you, because it doesn’t seem to be a problem with postcrossing, since other users would have already contacted us here.

1 Like

Problem Solved!

I’m not into technology at all, so I had no idea what she meant when my daughter asked if I’d cleared my cache. Anyway, she cleared it, I tried again, and the photo has uploaded.

Thanks everyone for your help.


I’m a bit late, but I had a quick look on the server logs and it seems the server was giving up from waiting for the upload to complete, possible because the connection was idle for too long.

It’s tricky to debug these things and know exactly what was causing it, but it’s good to know what worked to sort it out as it may be useful for others to know if they get the same.


is there any solution yet? cos I have this same problem: can’t upload a photo of a recently sent card 14-2-2022

This is what helped me (quoting from two posts above):

"Problem Solved!

I’m not into technology at all, so I had no idea what she meant when my daughter asked if I’d cleared my cache. Anyway, she cleared it, I tried again, and the photo has uploaded."

I’ve not had a problem since. All photos have uploaded successfully.

tried that, didn’t work. But anyway, thanks for your reply.

However, after restarting my computer, it works again :slight_smile: thanks.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.