[FIXED] Help! I can't upload pictures!

Hi everyone. Greeting from china!

I can’t upload pictures both in topic and private message since last night. I changed my phone and even use computer to try but get the same results. The uploading is always 0%.

It really troubled me since l swap frequently these time and need to upload my proof.
But it seems others can upload normally. I don’t know whether other Chinese can also upload pictures?

Many thanks

1 Like

The upload mechanism works for me, on both my phone & laptop.

Maybe using a VPN will help?

1 Like

Do you use a VPN when unloading the pictures?
I got a temporary VPN now. But l have no idea with this problem

1 Like

I do use VPN when uploading.
I just tried turning off my VPN, and it also got stuck at 0% :joy:

1 Like

Yes!!! So strange. I have no idea about it

1 Like

Take a look at this thread, as you see, in this case it was solved by clearing cache, although it is regarding the official site.

However, maybe @paulo can work it out.


Thanks for your advice!! I will try!


No, I cleaning my iPad and iPhone’s cache, but still can’t upload images in Furom.


Well. Since we are all Chinese.it may be limited by the Chinese Internet


I am not sure. Because is no problem for downloading or upload in other websites.


I hope it is solved sooner or later. If I read something in other thread, I’ll tel you both.


The image upload method changed a couple of days ago by enabling direct upload to Amazon S3 (which hosts Postcrossing’s images) to make the upload process faster. This seems to be working well for most people, so it seems there’s some issue specific to the GFW.

This is unexpected as my understanding is that the Amazon S3 works in China, but apparently doesn’t seem to work for this particular use.

Anyone from China who knows more about GFW limits that can comment on this?



搞个VPN! 可以传的上去! 就是麻烦一点😂
Hope it can be solved quickly!

A simple search tells me Amazon S3 is blocked in China Mainland, maybe since 10 years ago.

Just search “Amazon S3” then you can find the it is on the list.

This link tells that AWS does have two regions in China Mainland, in Beijing and Ningxia Province. But it is only open for companies, and probably requires the permit from local administrations.

My friends tell me that Azure of Microsoft might be available in China Mainland.

1 Like

Some analyze (may not be correct):

When uploading on forum, it gives a request to postcrossing-forum-upload.s3.eu-central-1.amazonaws.com

It should be solved to IP address like:, or others in the same pool. I did not check them all.

By a ping test, this IP address works fine in China Mainland:

However, test on postcrossing-forum-upload.s3.eu-central-1.amazonaws.com is not good.
Almost all the nodes in China Mainland receive 100% loss on it.
We can see that the URL is not resolved to a correct IP.
This domain is under a DNS cache pollution.

By the way, domain postcrossing-forum-upload.s3.dualstack.eu-central-1.amazonaws.com works fine:

Perhaps changing the URL of uploading connection may help?

I do not know whether it will help, but adding this line in the hosts file may function?
在hosts文件里面加入下面的的文本,或许会有用?我自己没测试过。 postcrossing-forum-upload.s3.eu-central-1.amazonaws.com



1 Like

I have move this topic to #communities:chinese so that it can be discussed in Chinese too.

1 Like

That page mentions s3-ap-northeast-1.amazonaws.com and s3-ap-southeast-2.amazonaws.com specially (which are S3’s Asia-Pacific regions). I don’t know if those region are blocked, but we are not hosting in the Asia-Pacific area. We only host on the US and EU regions of S3.

The fact is that Postcrossing’s images (both on the main website and on the forum) are on S3 and postcrossers in China can see them fine (without VPN), so the relevant part of S3 is not blocked in China. The issue however seems to be related only with upload. Perhaps the GFW blocks certain type of requests.

Can someone check for any errors (or timeouts) on the browser console when uploading an image here on the forum?

1 Like

The point is that the forum have different URL for uploading and downloading images.

URL for downloading images has dual-stack mark in it. And it works fine.

URL for uploading images does not have a dual-stack mark in it. And that URL is blocked by the method of DNS cache pollution.

That’s why users from China Mainland can view pictures, but cannot upload pictures.

Analyze process is in my precious comment.

A possible solution for users is to add the correct IP address for the uploading domain.

GFW blocking methods is not only limited to IP block.
DNS cache pollution, keyword block and etc are also available.
This time, some domains of Amazon S3 in Germany is blocked by DNS cache pollution.