Navigating from forum to main website, gives forum error message (Safari only)

Here’s a screenshot. I’m getting this message a few times now tonight when navigating around the main website. I wanted to go to my traveling cards screen but it gave me this error msg instead.

1 Like

This is quite unusual - can you try restarting your web browser just in case it’s having a bad day? :sweat_smile:

If the issue remains, which link (on the main website) did you last press to land on that forum error page? And can you share which (forum) URL is the browser opening when you land that error page?

2 Likes

I had that issue earlier today, whenever I tried to access my sent / received / wall. (Chrome browser on iPhone) Now, though, it works fine … :woman_shrugging:

2 Likes

I was using Safari on my iPad.
I clicked on the house shaped button to go back to the regular Postcrossing website after using the forum, and that’s when the error message occurred.

If I remember correctly, after the error message appeared, I clicked the forum button and that’s what cleared it. It was late at night :sweat_smile:
I am also guilty of having a lot of tabs open on my browser right now too :sweat_smile:

Thanks.

1 Like

Mine is fine now too, it was just during that window of time late last night for me, which would be morning in Germany? Do you remember approx what time it was for you? I googled it and there is a nine hour time difference (between my city and Berlin, Germany, as I am not sure exactly where you are). I am in the USA, on the west coast.

1 Like

@paulo Oops it happened again just now:


when clicking on the amount of sent cards …

Weird … happened three times now, but as I‘m trying to recreate to grab the URL it‘s ok again … :thinking:

2 Likes

That first screenshot is… odd. You are seeing Postcrossing, and yet, the URL says you are still in the forum. :thinking:

I can’t reproduce this with Chrome nor Safari on iPhone, so something else is happening and is not triggering for me.

I have made a couple of updates in Discourse, but it’s unclear whether it will make a difference. Please continue to report if it still happens. In particular, it might help to know the URL of the forum page that shows that error (second secreenshot).

4 Likes

Thanks for all your hard work :blush:

Just to let you know I’m still getting this, examples are when I try to view my travelling cards through the drop down & also via ‘view all’ on the main page, plus when I try to view cards in the gallery, and sometimes it takes me to the forum instead of what I actually requested. It’s not every time but multiple times per day since the update x

1 Like

For those experiencing this, I’m trying to confirm a pattern. Can you confirm if

  • you are only seeing this on a iPhone/iPad?

  • that you reach the main website via the house icon at the top

1 Like

iPhone & yes, via the house :house: x

2 Likes

A post was split to a new topic: Translation in Firefox

  • yes, iPhone and Safari.
  • yes, the house icon. After clicking “Forum” button and going back to the forum, there is no more error even if I try multiple times.
  • I can reproduce the same issue again: logout, close the tab, open a new tab to sign to main site, go to forum, press house icon and then “page does not exist” error comes back.
2 Likes

@EmmaG @iamfromhk & others who can reproduce this

  • When using Safari, are you using it in private or regular mode?

  • Did you ever installed Postcrossing’s web “app” on your device?

It’s clear this is Safari related (perhaps a bug in Safari itself), but only triggers for some people. I have tried multiple times, including following these steps, and never triggers for me. :confused:

2 Likes

Regular mode & no, I’ve never installed an app x

1 Like

Twice now when I have logged out, the system has bounced me to this screen (see pic) and not actually logged me out. I have had to tap on the Postcrossing icon/word and try again to log out, the system takes me back to the main page, I try again then it actually logs me out normally. :woman_shrugging:t3::upside_down_face:

More info that might be helpful - both times, I didn’t log out directly from the forum, I logged out from the home screen.

Also, I am using a mobile phone, not a tablet or ‘proper’ computer.

Thank you. :smiling_face:

Just tried to log out after submitting this and it did it again! :nerd_face: Definitely a bug, this has never happened before!

It’s also done the same thing when I wanted to look at my travelling postcards. :thinking::face_with_monocle::upside_down_face:

As an temporary experiment, I’ve changed the home icon to open Postcrossing in a new tab window. For those that experience this, can you report back whether that helps somehow? Please make sure it opened on a new tab; if not, refresh/reload the forum and try again.

4 Likes

That does seem to have fixed it :blush:

3 Likes

I always use Private browsing on Safari and no I don’t use the web app. :smiley:

2 Likes

It’s fixed if opened in a new tab :heart:

2 Likes

Problem seems resolved. Thank you.:pray:

1 Like