Keyboard does strange things

Today I wanted to report a few cards on my favourite RR’s. Usually it takes me 15 minutes, now it took me almost an hour. I work on an Ipad and when I typed the keyboard kept disappearing while I was typing, causing me to click a link which opens and I suddenly find myself in a webshop or on another pcpage. When I go back, my text is gone and I have to start all over.
So I typed my text in a Note-app and copy-paste in to the textfield on the forum. The only thing I had left to do was type the names of the ones who sent me cards. But even that was a problem.
In my note-app and in the messenger app, my keyboard works fine, so I think it has something to do with the site. Could you check it out, please?

Everything works flawlessly on my smartphone…


Whenever I get strange effects on my iPhone or iPad, I turn it off, wait a minute, and turn it on again. That reboot process clears up things that may be scrambled in the memory.


Thanks for the tip. I tried it, but it still doesn’t work properly.


I had some trouble earlier trying to tag users. The tag worked if I completely typed a name, but it wouldn’t bring up the drop down list of names as I typed.

It seemed to start working again though.

I have similar trouble with my iPad on Postcrossing. The only way to get it to work well, is to type verrrrry sloooowly.

It is nice to know I’m not the only one, Typing slowly seems to work, but it is annoying that it will take so much time to type the messages. I hope there will be a solution.

@FeNa, @aerobear: Are you using the latest iOS version? Have you tried with the Discourse app?

@FeNa: Could you give a try with Safari to see if there’s any difference?

@aerobear: Was that with Chrome too?

I’m using iPadOS 14.8. Not using Chrome at all. Have not seen this problem on the Discourse server, but I also haven’t typed much on Discourse.
The wonky keyboard problem seems to be not happening at the moment. Don’t know if it’s fixed, or if there are other factors that affect it.

I’m typing this on a old (2013) iPad with iOS 12 and it seems to work: not super fast, but the keyboard doesn’t seem to disappear (for me, that is).

Does that happen in replies too, or only when editing long posts (eg: editing RR)?

The username autocomplete seems to work here too, so I wonder what else may be causing that. Was it always like that or is it a recent thing?

Just to be clear, I was talking about the Discourse app (that you can install), not their forum. Does the keyboard issue go away when using our forum through the Discourse app?

I’m using an IPad Air 2, circa 2014. For me, the keyboard doesn’t disappear, but the keyboard can’t keep up with the speed of typing, (there will be long pauses before the letters appear in the words I’m typing) and it will also randomly duplicate letters, and grossly misspell words by inserting letters I did not touch. It seems to be associated with unwanted “clicking” on things I did not click on as I’m scrolling, as if the keyboard is suddenly hyper-sensitive.

There is an autosave check mark (see photo) that seems to be involved in the keyboard problem. I notice that as the check mark struggles to keep up, the weird delays and typos happen.

I meant to say it doesn’t seem to be a problem on the Postcrossing Discourse app on my iPad, rather than the Discourse server.

Tried it on Safari, the keyboard worked perfect. So, the problem is with Chrome and not Postcrossing. :smiley:

@FeNa: I’m not familiar with Chrome on iOS: does it have extensions too? Did you install any? Might be worth trying to disabling them (temporarily) to see if it’s one of them causing that.

@aerobear: When I tried with mine, it wasn’t super responsive — but it is an old(er) device so that may be the cause for that and I suspect it might be the case with yours too.

Please bear with me: can you confirm for me that this problem happens both with Safari and with the Discourse app?

Can confirm it does happen with Safari, but not (yet) with the Discourse app. I have not used the Discourse app enough yet for a good data sample.