Issues Uploading Images in App

Hello PostAdmins,

For quite some time, I’ve been having issues uploading images while using the forum app. Particularly two issues.

  1. When uploading more than one image, the app will occasionally only add one (random selection, not necessarily the first selected). I’ve included screenshots below of my selecting multiple images, then only one being uploaded.

  1. This has been occurring a lot today where I will attempt to upload an image, but I’ll receive an error saying it couldn’t be. I’ll immediately attempt a second upload of the same image and it’ll work. I don’t have screenshots yet, but the next time it occurs, I’ll add them to this post.

Thanks for your help!

I’ve tried to reproduce this a few times, but it always worked. Will leave this topic here for a while in case others experience the same and can report it too.

This looks looks like it’s Android with the DiscourseHub app — yes?

When that happens, if you try again with the same photo selection, does it work then or does it consistently fail?

Does the error say anything in particular about what happened?

This could be related with the first issue: it may be that when selecting multiple images, if for some reason some of them fail, it will silently skip them resulting on the behavior you mentioned.

I was able to finally recreate the error message just a few hours ago!

It could be due to many things, even connection problems that I wouldn’t be able to reproduce.

I’m assuming trying again usually works?

Does it happen very often?

I don’t use the app but have the same problem when using my phone’s browser. When I select more than one picture for upload, it only uploads one of them.

Always or sometimes?

The app and a mobile browser should behave almost the same. The app is mostly a wrapper of the mobile version of the website that you get on a browser, with a few small additions (like notifications).

Only sometimes.

Sometimes it takes 2 or 3 attempts, but I can usually get it to go through.

It was happening a bit for a little, but it’s tapered off. I guess it got upset because I told on it for messing up. :rofl:

Always, but I don’t upload pictures often, so I can’t tell you if it maybe works once in a while.

Which phone/browser is this with? Are you usually on wifi or cell data when it happens?

Fairphone 2 with Chrome and wifi connection

There’s an app?


Yes it’s through Discord.

I have a lot of trouble with uploading photos here too but nowhere else. I always am trying it with wifi and my connection is very stable and strong. I have a Huawei android phone. My issue is different though. When I go attach the photo, the window that pops up with the options of photos from my gallery is blank. It doesn’t happen every time but most times. And when it does happen, I can try multiple times in a row to make it work, I can wait awhile to see if things will load, too, but it doesn’t work. I just have to try again much later.

Yes, you can use the Discourse App on your mobile phone.

1 Like