[INCOMING FIX] Postbot sometimes doesn't reply

Feel a bit unsure, so I ask here:

I want to draw 3 winners for my lottery. I pinged/tagged the postbot with 3d87 but I didn’t get a reply from him.
Here’s the topic btw.

I remember that I read last year somewhere around the forum, it can be take a while, while the postbot is used in PMs or in other topics. I’m still not quite sure if it’s true or a problem in general.

Cleaned my cache and cookies, logged out, logged in, pinged/tagged the postbot again but nothing.
Won’t ping/tag the postbot to often so I ask here, if I did something wrong.
(Checked other closed lotteries before and the owner ask the postbot to roll the dices and it work normal)

Sometimes the bot is a little bit lazy :upside_down_face: and it needs a second or third try.
If your profil is set to English you should use “roll” and if it is in German please choose “würfeln”.


I did both and he didn’t answered, so I was unsure if it’s because of a problem or if he’s writing snail mails. cough

Then I will wait a bit more and come back around midnight. Thanks for the reply. Wish a nice evening and week.

Sometimes he needs to be grumbled at a bit too :wink: - look here :arrow_right: [LOTTERIE] Runde 12: Peace on Earth ☮ - #151 by Bille

I think you could try again with würfeln 3d87 but type it in the same line when you tag postbot. Right now it’s in a new line so maybe that’s why postbot can’t recognize the command.


The postbot is a very dumb and fussy bot… so unless you feed it exactly right, it will not comply. :slight_smile:

It needs to be on the same line!

Here it was right, but was on the wrong language for your account. :stuck_out_tongue: It will refuse to use roll if you are using the interface in German.

Still wrong language, but also had a bunch of spaces: between @postbot and roll you had 4 spaces! It doesn’t show after posting, but if you would edit the post you’d see that there’s extra spaces in there.

Here it was the right language, but still 2 spaces between postbot and würfeln.

Still 2 spaces. Sorry, I said it it was a fussy bot! :stuck_out_tongue:

3 spaces :stuck_out_tongue:

I don’t know what happened with this one — should have worked. Perhaps it was annoyed and the bot decided to ignore you for a while. :sweat_smile:

In short, the bot is very picky and needs to be fed exactly right: on a single line, and single spaces only. Anything else and you are in unknown territory. :wink:

/cc @moderators Extra spaces (and language) is usually what gets the bot to not be responsive. :slight_smile: Will report it to Discourse, maybe they can do something about this.


Hello paulo,

and thank you for coming back to me and all the informations.

Mysterious is, that I changed my language settings between using the postbot. As I thought he didn’t work in german, I change to english, switching between both languages didn’t worked.
The Forum starting page also didn’t changed during my language settings, also Cache cleaning, Logout and Login didn’t worked for me.

I will check out this again tomorrow, when I use him again and will do Screenshots if it didn’t work again.
So far, thank you again for the help. Hope you have a wonderful sunday and a good start into the upcoming week.


The Discourse team has already implemented a fix for the extra spaces so we’ll get it next time we update our forum to the latest version. :+1:


I experienced this a couple of times while using the interface in Italian. Where can we find the commands to use in other languages than English?

If you use a wrong command, postbot will reply, including a command (“help”) which will list all available commands when used. Like this: