Forum update (Discourse 3.1)

The software of this forum (Discourse) has been updated today to its latest stable version (3.1).

At the moment there are some problems with ocasional errors during image uploads and we are looking into that.

Meanwhile, if you bump into other new issues (or changes to share with others), please report them here.


I don’t know if it’s a bug, but I’m facing this image uploading issue
And today, non of my images were getting uploaded it just kept showing this message
I had to try several times to upload a single pic


Not sure whether this has anything to do with the latest “Forum update” or if it’s a “bug”;
The “blue circle” notification next to "read’ messages keeps on reappearing despite reading through the whole topic. Encountered this yesterday 2023, 21 Oct ~ 1700’s IST & 2023, 22 Oct 0752 IST Topc ~ “Lottery - Some Blank cards”

1 Like

When I got that error message yesterday I tried to upload the same image with a smaller resolution and then it worked.

1 Like

The image upload issues seem to be better now, although we are still monitoring it. One pattern that seems more likely to get an error is to try to upload (another) image while the previous one is still uploading: try waiting for the previous to complete first.

We are still looking into the occasional issues with visited topics not getting marked as read.


I’m not sure if the update is the issue, but I cannot access the forum with the Firefox (mobile) browser anymore since a few days, it’s just loading endlessly or I get “Login error”.

I have to use Chrome to get access. I didn’t make any changes in my Firefox settings, and all other websites are loading without problems - very strange. :face_with_raised_eyebrow:

1 Like

I have the same problem. Since a few days, my Samsung Internet browser tells me that this browser is unsupported now. I also have to use Chrome now for the forum. I use Samsung Internet for all other websites, so now I have to work with two different browsers on my mobile phone.


It may be that Discourse 3.1 no longer supports your browser. Can you double check that you are on a fairly recent version of your browsers?

For Samsung internet the latest is version 22.0, and for Firefox for Android I think the latest may be version 119.0.

1 Like

Based on the above, I also switched. It works perfectly through the Firefox application.

1 Like

I have had the same problem; most of the time Firefox only loads the forum page partly, especially when I use 4G, but I often have better luck of I use Wifi.
I wondered if my phone had hiccups and I even uninstalled and reinstalled Firefox, which didn’t help. Restarting the phone sometimes helped, but not always. I’m glad to see that the problem isn’t my phone.

1 Like

Which version of Firefox is it?

Seems like it might be working better now, though.

I just updated on 119.0.1, hoping that this will fix it. The website loaded one time completely on version 119.0.0, but I wasn’t able to browse on.

But it’s loading in vain again. :expressionless:

It seems specific to Firefox for Android (when loading Discourse), on some specific systems :confused:. It has already been reported to Mozilla some months ago.

For those being affected: are you on a Fairphone or Google Pixel?

In any case, for the time being, I’m afraid the only workaround is to use a different browser (or, perhaps, the Discourse Hub app).

I’m using a Huawei. After working for a while I’m back to not working on my phone.

My PC Forum app wasn’t working well so I uninstalled it with the intention to reinstall, but it seems to no longer be in the Android app store. Has the app been phased out or renamed?

Have you tried searching for “DiscourseHub” as the app name?

It will get me to the forum, but it’s not set up any different than in a web browser. It’s okay. I’ll just use the web browser