Doubleclicking the heart icon gives "You are not permitted to view the requested resource" message


I was browsing the Handmade Mail tag and wanted to like something, clicked the heart, then clicked it again and got this message popup: “You are not permitted to view the requested resource.”
That struck me as odd, so I did it again and got the same result. When I tried again, I didn’t get this popup, I got a different one: a message that I tried to click the heart too many times and needed to wait 50 seconds or so.
I think the first message I got might be a bug?

For me thi happens sometimes too if I opened the samepage in 2 tabs. In one tab I heart a post, in the other it doesn’t get tve heart I made in the first tab. When I then reloaf the second tab I vsn see I already hearted it

I’ve seen this message pop up but it was a different scenario, when I was flagging something but the post was also being removed at the same time. I tried to recreate your scenario wherein I click the heart twice in a matter of seconds, I don’t get the message popup but I got a ‘403 error’. It doesn’t always happen though, I got this error only once after 4-5 tries on different posts.