✅ Community inaccessible on PC

Note: The this topic is created via the community progressive web app (PWA)

My desktop PCs can no longer access the Community page. It returns a login error and ask me to contact admin.

(Screenshot captured through remote desktop)

The problem persists after purging cache & cookie, even switching browsers and on my laptop.

However, the Community remains accessible on mobile both through browser (Chrome) and PWA.

Looking at the account preference, it shows the account recorded the login from my desktop, but whenever I tries to logout the desktop session, it returns an error saying token id invalid.

Edit: The above “invalid token ID” error is likely caused by lag. It goes away after refresh. It happens when attempting to sign out an already signed out session (token_id is null).

I think there might be a problem related to single sign-on (SSO) affecting my account. Edit: the login problem seems to be system blocking desktop on the specific IP.

Update 00:29 UTC, 19/11/2020: I was able to temporarily log into Community page on desktop through a virtual desktop hosted elsewhere. This changed the IP that I used to access the Community, which seems to resolve the issue for now.

Update 00:40 UTC, 19/11/2020: I attempted “logoff all” from my phone from my home WiFi (using same IP as desktop), now mobile is showing the same “login error” as desktop. The virtual desktop using a different IP is unaffected. (Which is how I am still able to type this!)

I had a look at the logs and couldn’t find anything unusual. Also, activity (number of visits) seems to be within the normal pattern, so I suspect this is something specific to you.

My guess at this point is that perhaps that location is somehow unable to reach AWS which wouldn’t be uncommon for, say, an IP in China, but not common for Netherlands networks.

Can you give more details on the location of the IP address that is experiencing problems in accessing the forum? Can that same IP address reach the main website for example?

All devices (desktop and mobile) on my home IP (*, Delft, Zuid-Holland) can access the Postcrossing homepage, but whenever I try to navigate to the Community by clicking “Forum (NEW)”, it reports “Login Error: There is a problem with your account. Please contact the site’s administrator.” during SSO.

The virtual machine located at * (Delft, Zuid-Holland, currently in use) is not affected by the said error and can access both Homepage and Community.

Can your home devices open this?


Try logging out from your Postcrossing account on the main website and then go come to the forum again following the link the menu. Any difference?

Nothing changed on my home PC, still reported the same Login Error.

My virtual machine session logged off during the process, but was still able to login.

Any difference if you access the forum through it’s front page instead of the custom link of the menu?

Still shows the same Login error.

Any output on the browser console?

sso_login:1 Failed to load resource: the server responded with a status of 500 ()
c715b2206d6afb0e5a97509fd693bdab3f78393b.js?__ws=community.postcrossing.com:83 Uncaught ReferenceError: jQuery is not defined
    at c715b2206d6afb0e5a97509fd693bdab3f78393b.js?__ws=community.postcrossing.com:83
    at c715b2206d6afb0e5a97509fd693bdab3f78393b.js?__ws=community.postcrossing.com:83
sso_login:1 Failed to load resource: the server responded with a status of 500 ()

Try the safe-mode and disable everything. If that helps, disable only some things until understanding what causes it.

No changes after disabling everything. Still the same login error.

If I recall correctly, the SSO login/logoff issue was discussed in a few earlier posts. Could it be that a fix applied elsewhere is causing the issue?

I think it’s unrelated, since your account works elsewhere otherwise.

You said it also fails to work with other browsers on the same PC? Can you double check?

Do you have anything in your computer that may be blocking access to some URLs like a firewall or some security software?

I attempted to login on Edge and Chrome on my desktop PC, all returns login error. This is the same for my laptop. No additional security software is used other than built-in Windows Security.

My phone was able to access the forum (using previously save credentials) last night using home WiFi when posting the topic initially, but became inaccessible with the same error after the manual “logoff all” from VM.

If you try with that phone where it stopped working on wifi, but try now with mobile data (or some other wifi network), same thing?

I tried using mobile data and I was able to access the community page no problem. I can continue to use the page (without logout) after switching back to home Wi-Fi. It no longer works after sign out.

Probably this issue has something to do with my home IP somehow being blocked by a link in the authentication chain, which caused the login failure specific to this IP.

I have found something — can you give it another go?

Yep. Everything working now.

May I ask, what was problem?

Somehow Discourse had added that IP to its list of “Screened IPs”. It’s not clear to me why and in which cases that happens. Normally it would be to prevent multiple signups but that doesn’t apply with this forum. Please let me know if it happens again and apologies for the trouble.

Also, thank you for all the help (and patience) in tracing this — if it happens to others, then we’ll know where to look first.