Postbot

I came on here to ask a question but got bogged down with something called postbot. It is completely mad. Can you reply with a picture. I replied with its own picture. It said Looks like you didn’t upload an image so I’ve choosen* a picture that I’m sure you will enjoy. When I clicked on that link I got
Oops! That page doesn’t exist or is private.
Then it said Unfortunately, as a poorly programmed bot, I can’t quite understand that one. :frowning:

You can try again, or if you’d like to skip this step, say skip . Otherwise, to start over, say start tutorial . I said skip. Then it told me to flag a post. I flagged the post. Nothing happened except You have flagged this post for moderation appeared underneath the flagged post. Then it said Oh no, my nasty post hasn’t been flagged yet. I said I have flagged it. It said Unfortunately, as a poorly programmed bot, I can’t quite understand that one. :frowning:

You can try again, or if you’d like to skip this step, say skip
I said skip. It said you’ve already said that. I said skip skip. It said Aw, sorry. I’m still not getting it.

Meanwhile I still have not asked my question.

*there is no such word as choosen.

We experienced an “issue” with the bot on the sandbox, too. When you need to flag the post he asks for a specific flag. Have you chosen the right option (second from top)?

For the picture: Have you uploaded it as (single) picture or did you try to upload it as gallery? The correct option is highlighted in the screenshot below.

grafik

start tutorial .

start tutorial

now what?

Hello @SailingBy. It would probably be best if you started the tutorial all over again. Click on your avatar on the top right of your screen, then double-click on the envelope icon:

This will take you to your personal messages page. Click on the “New Message” button there, and you’ll get a message editing box. In the “Add a User” field, type “postbot” and in the body of your message, type “start tutorial.” Postbot will then respond to you and you can start the tutorial again.

When postbot asks you to reply with a picture, don’t reply with postbot’s picture: you’ve proven that for whatever reason that will not work as intended. Choose a picture from Google Images or your own files. Just drag and drop or copy and paste. Or heed @Cassiopheia’s advice above about clicking the Upload rather than the Image Gallery icon. Also heed her advice about the flagging.

It’s actually a good tutorial that I think you will enjoy, as long as you follow postbot’s instructions to the letter and don’t try to argue with it as though it were human and not a bot.

As for your question, you can still ask it here on this thread.

5 Likes

it works, I replied with his picture, too :sweat_smile:

1 Like

Started again, it won’t move past this

I don’t think you’re flagging the post as inappropriate, which is what the bot asks for.

He can be a bit finicky sometimes. :sweat_smile:

1 Like

I can’t find a way to re-flag it so I skipped.
Now I’ve got this

1 Like

That should be your certificate — congratulations! :tada:

It can take a bit to load. Just leave the page open, and come back to it in some time. When it does, you can make a screenshot and participate in my lottery. :blush:

I had the same problem when I made the tutorial the first time around in the sandbox. I flagged it as something else and couldn’t proceed. If this is fixable or if a warning could be added that nothing else works, that would be nice for newbies. I switched to pc and started the tutorial from the beginning again in that case because I somehow overlooked that you can skip steps, too :sweat_smile:
It would also be very helpful to add a notice that the image might take a while to load, I don’t know how often we’ve had to explain this already…

I also got stuck on this when I went through the tutorial initially. It was a bit frustrating because even once you realize your mistake, there’s no way to fix it.

I think Postbot is awesome. Mind you, I did what I was told, when I was told, how I was told…

I.
HAVE.
BEEN.
ASSIMILATED.

1 Like

The issue with the incorrect flagging has already been fixed on the latest version of Discourse and we will get the fix on the next update. Incidentally, I have also reported that the capybara doesn’t eat real emojis and they fixed it in 30m :star_struck:. Again, also available here when they release the next stable version and we update to it. Oh, and the “choosen” typo had already been fixed too when I checked.

As for the certificate, it seems that sometimes it takes a while to generate for some reason, and only some times: I just redid the tutorial and it showed pretty much instantly for me. I have reported this issue to the Discourse team, but it may be tricky to address if they can’t reproduce it on their side. Will update here if I hear from them on it.

5 Likes

Thank you for attending to these relatively minor issues. :smile:

1 Like

Congratulations! :slightly_smiling_face:

Great

How can I use the postbot? I am trying to start the tutorials… I think I will need to use the Dutch word for it, that’s no problem, but what do I need to do to start them? I have over 30 messages now, doing nothing ::

Try: @postbot start tutorial and follow his instructions :wink:

Normally you message the postbot with a command like:

@postbot start tutorial

or

@postbot start advanced tutorial

Something to be careful about is with copying&pasting the commands — we’ve had some issues with that in the past. Sometimes doing that will also copy the style of the text which causes the bot not understand the text part of the command. The simplest way to avoid is simply to type the command instead of copy&paste.

2 Likes