Copying from WORD-files into messages

Discourse is sometimes not funny…
Today I tried to copy an address list from WORD into a message.
With the result that Discourse inserted a blank line after each address line.
So not as it should be, like this:

Mrs. Anyone
Hallihallostr. 34
12345 Nowhere
Switzerland

but

Mrs Anyone

Hallihallostr. 34

12345 Nowhere

Switzerland

Stupid.
After a long time of trial and error I found out that everything is ok as long as I only copy a maximum of one page from Word. From one page + one line on this empty line crap comes.

Dearest Mr Baer, I’m sorry you had this unpleasant experience! I wonder if you have tried right-clicking into Discourse when you paste and choosing “Paste and match style”? Does that make a difference at all?

Can you also try pasting without format?

On Windows that’s Ctrl+Shift+V and on MacOS +Shift+V.

6 Likes

That trick has helped me and others!

1 Like

Yay! That has worked! Thank you all! :slight_smile:

3 Likes

I was very annoyed by this when I sent my first round of addresses a couple days ago for my RR. I went in and manually removed each individual extra line. Next time I will try to paste without formatting, as suggested.

What a great shortcut!
For all sites, I copied firstly into Notepad, then into the form, it turned out I made so many unnecessary actions :rofl:

1 Like

Dear all,
I have the same problem with spaces getting messed up when I copy & paste from a Google Docs.
I actually also tried from Word, but nothing worked, neither copying one page at a time, neithe ctrl+shift+V (this actually doesn’t do anything to me).
If anyone has any other advice, I would be very grateful! :frowning:

Odd, that should work — try selecting something small (eg: just a line or two) from the Word doc and do the same ctrl + shift + V (this assume you are using Windows).

If that works, that the times it doesn’t work is because you are trying to paste something that can’t be pasted that way for some reason — could be an image or some odd formatting that can be converted to “no style”.

I tried again, I found out my keybord has a “function” key that does the job, so to me it’s

ctrl+fn+v

However, it only works with the first page on the text, when I try to do the same pasting the second or the third page it goes back to adding spaces.

You can try right clicking, then select Paste Special, then text only or without formatting. This is the same thing as ctrl shift v.

No help of you’re on your phone though.

But if I right click in the editor, I only get the standard “cut-copy-paste” options, no way to do a text only pasting… :thinking:

In Chrome, there is an option ‘paste as plain text’.

(I wrote my first response with insomnia in the middle of the night on my phone - should have waited to check!)

I see.
I use Firefox, that might be the reason why I can’t see this option.

If you cannot make it work with the keyboard shortcuts just copy the text in any plain texteditor (that has no formatting) like the good old Editor on Windows. All formatting will be lost due to this, so no problem in copying it over here then.

grafik

4 Likes

The Ctrl + Shift + V is a fantastic resolve.

In Word, you can also use Shift + Enter for line breaks, which will provide you with a continuous flow of text whereas only Enter indicates a paragraph change and results in a space between “paragraphs” when pasted elsewhere.